Up Owners Club banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Good evening everyone,

My air conditioning won't turn on on my 2014 UP. There's also an issue with the hazard light, rear defroster, passenger airbag warning light switch.

Last week I had the radio out to remove the Maps & More cabling & to run a USB & aux cable through for my phone. When removing the cable, there was a spark, after which the radio had no power & to the hazard light, rear defroster, passenger airbag warning light also.

I've changed the fuse in the back of the radio & it's now working. The maps & more cable has been disconnected from the radio & it seems to be fine.
The hazard light, rear defroster, passenger airbag warning light doesn't light up or react to being pushed, but if I unplug it, the airbag warning light in the instrument cluster comes on.

A few days later (after a few days in the mid 30'sC including 2x 1 hour drives, I woke up on Sunday to the a/c blowing only hot air.
I went to an air condition specialist & he said all the hardware seems fine & the gas system isn't leaking & is topped up, but his computer couldn't get a signal from the air conditioning controller. The a/c button does light up when pressed & there is a click from where I believe the relay is under the steering column (LHD) but has no effect, by Tuesday the rotating knob to change where the air comes out doesn't change where the air comes out!

I've checked all 50 something fuses by the pedals & the 3 blade fuses by the battery & they are all fine. I've paid my E7 for the hours access to get all the VW workshop & servicing guides, but I'm just scratching my head.

Does anyone have any ideas what to do? I can only thing to replace the a/c / HVAC controls & the other switch unit, but thought I'd better check before splashing all that cash.

Thanks in advance for your suggestions!

Tom
 

·
Registered
Joined
·
2,694 Posts
Ignition switch has been known to cause problems.

But thinking of the radio, it may be worth investigating the 12V DC-DC converter, a kind of voltage stabilizer, which keeps a solid 12V on for some systems when starting the car.

I assume you have disconnected and reconnected the main battery to force a cold reboot of the cpu-based control systems....
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the speedy response, I've just disconnected the battery for 10 mins, after reconnecting & warming the engine, I don't notice a change with the a/c switched on (other than the orange light & click). and the switches still aren't responding, the airbag warning light is still there, but torque pro can't find any fault codes.

Where would i find the 12V DC-DC converter?
I'm frustrated & probably not thinking too logically atm! thanks again
 

·
Registered
Joined
·
2,694 Posts
Ignition switch still a possibility, but the battery and 12v stabilizer are long-shots....
Font Parallel Screenshot Circle Brand
 
1 - 5 of 5 Posts
Top