Up Owners Club banner

1 - 20 of 39 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
Hello all,

I've just tried installing one of these Auto Headlights Kits to my 2018 UP GTI (which doesn't have City Emergency Braking and therefore no auto headlights/wipers):


Unfortunately, it doesn't appear to work - the headlights come on correctly but the fog light switches seem to be disabled. Has anyone had any success with one of these kits on a GTI, in which case I'd really appreciate a link to where I could get one that actually works ....

Thanks!
S
 

·
Registered
Joined
·
176 Posts
Have a wander over to the Audi A2 Forum, I bought one Via a link on there and everything worked as it should,Perhaps the wiring is different??
Anyway good luck
 

·
Super Moderator
Joined
·
985 Posts
As T&biskits said, the kit I have on mine you have to move the switch into the sidelight or headlight on position for the fogs to work, it doesn't pull out when in the AUTO setting, probably to stop you leaving the fogs on when you leave the car by accident...
 

·
Registered
Joined
·
140 Posts
As T&biskits said, the kit I have on mine you have to move the switch into the sidelight or headlight on position for the fogs to work, it doesn't pull out when in the AUTO setting, probably to stop you leaving the fogs on when you leave the car by accident...
Always new i was **** at explaining stuff.
 

·
Registered
Joined
·
140 Posts
Push original light switch in, on O setting & turn to sidelight ( loads of video`s on web showing how to do it)(
) , then the switch just pulls out, unplug wiring. New one won`t go through gap behind switch with wiring plug attached, so just pull off end panel on dash,fit new light switch, through the end of dash with panel off, attach wiring plugs, then run sensor cable to where ever you want the sensor to sit, i ran mine up door seal & it pokes out from the top of the A pillar.Done in 10 minutes
 

·
Registered
Joined
·
75 Posts
Can anyone who has installed one off these switches confirm that both the front and rear fog lights work and that the relevant light symbols appear on the dash display.

As I have only rear fogs don't think I will bother.
 

·
Super Moderator
Joined
·
3,092 Posts
Easy Peasy...bought two kits and had the Amarok and Up! GTi done in 10 mins! A simple and worthwhile mod! (Once you know the secret to taking out the switch!)
 

·
Registered
Joined
·
46 Posts
Discussion Starter #13
Easy Peasy...bought two kits and had the Amarok and Up! GTi done in 10 mins! A simple and worthwhile mod! (Once you know the secret to taking out the switch!)
... but did the foglights work correctly? If so may I ask which particular kit you used? I've tried two now and neither worked!
 

·
Super Moderator
Joined
·
985 Posts
I bought my kit off eBay, there are 2 versions depending on which plug you need. Early Ups use a large 17 pin connector that looks like this:

4490


This goes into a box that controls the auto lights and has a light sensor wire that you run somewhere on the dash. You then plug the output wire into the headlamp switch that comes in the kit and it's done. The kit looks like this

4491


On my GTI, I bought an earlier kit thinking it would be the same, but VW have changed the connector plug onto the headlight switch to a small 10 pin plug that looks like this

4492


So I bought this kit instead

4493


Run the light sensor to somewhere on the dash, plug it all in and away you go. All lights work exactly like they should do, including cornering fogs so no problems what-so-ever.
 

·
Registered
Joined
·
140 Posts
... but did the foglights work correctly? If so may I ask which particular kit you used? I've tried two now and neither worked!
I have just tried ours. Pull light switch out (first click out) on sidelight/main headlight, front fogs on, no light on dash,pull out to the second click on both sidelight & main headlight, both the front & rear fogs are on & the light denoting fogs are on is displayed.
 

·
Registered
Joined
·
46 Posts
Discussion Starter #16
I have just tried ours. Pull light switch out (first click out) on sidelight/main headlight, front fogs on, no light on dash,pull out to the second click on both sidelight & main headlight, both the front & rear fogs are on & the light denoting fogs are on is displayed.
I bought my kit off eBay, there are 2 versions depending on which plug you need. Early Ups use a large 17 pin connector that looks like this:

View attachment 4490

This goes into a box that controls the auto lights and has a light sensor wire that you run somewhere on the dash. You then plug the output wire into the headlamp switch that comes in the kit and it's done. The kit looks like this

View attachment 4491

On my GTI, I bought an earlier kit thinking it would be the same, but VW have changed the connector plug onto the headlight switch to a small 10 pin plug that looks like this

View attachment 4492

So I bought this kit instead

View attachment 4493

Run the light sensor to somewhere on the dash, plug it all in and away you go. All lights work exactly like they should do, including cornering fogs so no problems what-so-ever.
I'm mystified. I got 2 kits like the one pictured above with the smaller plug, and neither operated the foglights. Maybe I'm missing something. We are talking about an UP GTI here aren't we?
 
1 - 20 of 39 Posts
Top