Up Owners Club banner
1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi...I used to connect my phone (Xiaomi Redmi Note 9 Pro) to my VWUp (2011) via bluetooth without any problems, until recently there was some updates to the phone, and it stopped connecting to my car. Car finds phone, connects, disconnects and re-connects....keeps on doing it on a cycle. Does anyone know what happened and if there is any way to solve it? Other phones connect normally.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Phone is only 1 year old. Still under guarantee. They checked it, didn't find any fault with it. Bluetooth works fine with all other devices. Took car to auto electrician (car is also still under guarantee), and they also said problem isn't with car since other (older) mobiles connect just fine. So problem came with Xiaomi's latest updates!
 

·
Registered
Joined
·
2,702 Posts
yes - Bluetooth implementations can have bizarre incompatibility issues.

I bet many other brand-new phones will work with your car too, but you've been unlucky.

Sounds like Xiaomi have actually broken something in this case with recent firmware changes, but you will get absolutely no support for the phone... Maybe a future "update" will fix it, maybe not! Are you sure you meant a Xiaomi update or have you updated an app.

If it were me, I'd factory reset the phone and start again with Xiaomi updates first, checking that is OK, and then re-loading your apps one at a time and checking This sometimes works - it can get rid of artefacts from previous firmware or security updates, but also, it may be an app you have loaded that uses Bluetooth that causes the problem, and if so, you may be able to identify it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
100% a xiaomi system update that happened 2 weeks ago. Trust me if I say I did factory reset about 5 times..loading /re-loading apps. Left it a week at a mobile technician. Got it back & left it for another 2 days and still issue hasn't been resolved. He too told me to wait for some 'future' update to possibly fix the issue. In the meantime he asked me to check on forums to see if anyone else has encountered any similar issue....hence my post ;)
 

·
Registered
Joined
·
2,702 Posts
Good to hear that it's not any single app at fault - as that could affect non-Xiaomi users too.

Call me a cynic, but I'd be surprised if this issue gets fixed - especially as you're not saying that you have come across other people reporting the same fault to Xiaomi or elsewhere on the 'net - mobile phone makers are utterly ruthless :( I'll be glad for you it it does get resolved!
 

·
Registered
Joined
·
2,702 Posts
I saw this with a quick search:
https://www.reddit.com/r/Xiaomi/comments/hx4h5y and
and

so there are others, but unless hundreds or thousands of people complain, you become what's called "a corner case", and it's not worth their while for the company to act....
 

·
Registered
Joined
·
2 Posts
A temporary workaround that I've found is that any time you want to connect to your car's Bluetooth, you'll have to unpair/ forget that pairing on your phone and then go through the reconnecting sequence and then it works fine for the duration of that trip. But you'll have to do it each time you want to use Bluetooth which is annoying. Good luck!
 

·
Registered
Joined
·
2,702 Posts
Shouldn't have to though - mine works for the last 2 years without a faff....
I suspect there is still an incompatibility... :(
 

·
Registered
Joined
·
14 Posts
Hi...I used to connect my phone (Xiaomi Redmi Note 9 Pro) to my VWUp (2011) via bluetooth without any problems, until recently there was some updates to the phone, and it stopped connecting to my car. Car finds phone, connects, disconnects and re-connects....keeps on doing it on a cycle. Does anyone know what happened and if there is any way to solve it? Other phones connect normally.
Have you found any solution to this?
I Have exactly the same problem you describe to the letter: after MiUI 12.5 update Xiaomi phones on a constant Bluetooth connect/disconnect loop. Two different Xiaomi models (Mi 9 SE and Mi 10T lite) do exactly the same, while any other phone connects with no problem.
Also, the same as you, I can un-pair and re-pair, and it will work for the duration of the trip, but the problem returns when you turn the ignition off and on, so only lasts for as long as the car is running.
Tried deleting Bluetooth cache/data and re-setting Bluetooth on the phone, but that didn't help. Probably needs a fix from Xiaomi, but will they bother?
 

·
Registered
Joined
·
2,702 Posts
There is almost no chance of a fix, I reckon. I suspect you'll need to use another brand of phone.
 

·
Registered
Joined
·
1 Posts
Hey guys...I have found a shorter workaround. Go to ''Developer options'', scroll down to ''enable bluetooth page scan'' and turn it off. Now you will have to manualy select a device to connect to in bluetooth menu, but there is no need for constant pairing/unpairing. Fingers crossed Android 12 and MIUI13 fix this issue.
 

·
Registered
Joined
·
1 Posts
I have the same issue with my Xiaomi Mi 9 and my new Xiaomi 12. However, VW Taos works fine on both phones.
It looks like the compatibility issue of Xiaomi's Bluetooth implementation.
 

·
Registered
Wolkswagen Up 2013 44kw 1.0 gazoline
Joined
·
3 Posts
Hi...I used to connect my phone (Xiaomi Redmi Note 9 Pro) to my VWUp (2011) via bluetooth without any problems, until recently there was some updates to the phone, and it stopped connecting to my car. Car finds phone, connects, disconnects and re-connects....keeps on doing it on a cycle. Does anyone know what happened and if there is any way to solve it? Other phones connect normally.
It's Xiaomi's fault from the latest update, i have same problem with my Poco F3 that keeps disconnecting
 
1 - 15 of 15 Posts
Top