Up Owners Club banner
1 - 20 of 20 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter · #1 ·
Hey everyone,
just letting you know, that recently my 2019 e-UP! started to refuse to charge bcs it thinks I have no P on the gear selector even tho it is in the P also my dash shows P. The light on the charging socket is just flashing yellow/orange after plugging the charging cable.
I decided do do the full scan with VCDS cable and found nothing obvious, no error codes related to the charger module or other related components. I dug deeper and found e-Golf owners complaining about some microswitch going bad in the gear selector. I give it a go and I ordered new gear selector mechanism for 179 eur incl. VAT at dealership part no. 12E713025G (this thing had 4 revisions already vs. my old part in the car ending with letter C). This weekend I am planning to install it. Hope it will help to mitigate the issue. If anyone else had similar problem, i would like to hear your experience. Will keep you updated ...
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #2 ·
Update - it took me 2 hrs to replace the gear selector, the most trickiest part to remove was the decoration panel beneath radio, there are 12 clips and they are holding strong, the position of them is on the picture. Use plastic L or J shaped trim removal tool and pull hard towards you from top side first
 

Attachments

·
Registered
Joined
·
33 Posts
Discussion Starter · #3 ·
Then just unscrew 4 torx screws (2 up, 2 below behind selector cover), remove buttons and cigarette lighter part, the tabs are on top and bottom of left side, then remove selector cover (do not push the button) and unplug it. After that remove lover cover panel, it has 2 easily accessible torx screws and the rest is holding just on clips.

Before removing selector, unscrew cable holding bolt (10mm) on the left side, then unscrew 4x 10mm bolts holding the mechanism, of course don't forget to unplug cable attached to it.

After that remove selector mechanism and cable ending from the ball joint and attach it back to the cable - do not tighten screw yet, this needs to be done after assembly.

Installation is reverse of removal, dont forget to pull cable towards you to engage P in the gearbox and tighten the screw holding the cable to the bracket.

FYI - replacement of this mechanism FIXED my issue.
 

·
Registered
Joined
·
2,702 Posts
It's upsetting to spend €179 when your warranty has expired, for the sake of a €2 microswitch!
 
  • Like
Reactions: shemmo

·
Registered
Joined
·
33 Posts
Discussion Starter · #5 ·
It's upsetting to spend €179 when your warranty has expired, for the sake of a €2 microswitch!
yeah, i agree, i could just have replaced the microswitch but the car won't be running until then and my partner just needed the car to be up and running so i decided to get a new unit :)
 

·
Registered
Joined
·
33 Posts
Discussion Starter · #10 ·
Good work fixing it! Out of intetest how many miles has the car done?
I am debating keeping ours past warranty and things like this are useful to know about.
My car has 47 000 km (29k miles) soon to be 3yrs old. We had only standard 2 years warranty, if you have a chance, buy prolonged 5yrs warranty, it is worth it.
 

·
Registered
Joined
·
4 Posts
I have had the blinking yellow when connecting the cable from my wall box three times now coming home from work on my e-up 2020, 36 000 km. The only way to get it going has been to start the car, select any gear and back to P and turn off. Then the charging starts. My two year warranty is gone.
 

·
Registered
Joined
·
2,702 Posts
Could be the micro-switch on the selector stalk. If so, not much money....
 

·
Registered
Joined
·
2,702 Posts
Dunno, but there will be a means somewhere in the selector lever to identify to the control electronics what position it is in - usually done with switches or with sensors... It's a similar thing on automatics with IC engines.

It may be that the selector lever assembly cannot be disassembled, perhaps like a wiper or indicator stalk, and if the fault is within it (we don't know, and are only guessing at this point) it may need replacing. Hope not !
 

·
Registered
Joined
·
4 Posts
I called VW and she told me that the problem with flashing yellow seems to be a common problem. Either the repair is free or I'll have to used my
insurance and then it would cost me 1 500 SEK (about $150). She's gonna investigate more and come back to me.
 

·
Registered
Joined
·
3 Posts
I called VW and she told me that the problem with flashing yellow seems to be a common problem. Either the repair is free or I'll have to used my
insurance and then it would cost me 1 500 SEK (about $150). She's gonna investigate more and come back to me.
Ok, thats good. I solved the problem by loosen the screw for the cable to the gearbox, and then tightened it again. Seems that it just needed some adjustment😁.
 

·
Registered
Joined
·
2,702 Posts
Sounds like a micro-switch not quite making or breaking somewhere - but good that it is sorted!
 

·
Registered
Joined
·
3 Posts
After a bit more trouble-shooting...another way to test is to park the car up- or downhill. In my case it´s working ok parked downhill, but not uphill.
I guess the force on the gearmechanism affects a microswitch in some way :) . Still has to be fixed, but later :cool:
 

·
Registered
Joined
·
4 Posts
Tomorrow VW's gonna fix my car. Since three days ago I just can't charge the normal way. Yellow slow blink as the lever is not in P. Ignition on and the charging never fails. Strange i think but that's the way it is now.
 
1 - 20 of 20 Posts
Top