Up Owners Club banner

141 - 160 of 177 Posts

·
Registered
Joined
·
310 Posts
Phew !

You would think an aftermarket specialist would have this nailed by now and be on this forum......(just saying)

Dealers really can't get their heads around it, well mine can't anyway :sad:
 

·
Registered
Joined
·
38 Posts
Phew !



You would think an aftermarket specialist would have this nailed by now and be on this forum......(just saying)



Dealers really can't get their heads around it, well mine can't anyway :sad:


Try vagtec.co.uk they seem to do lots and install. I’m going to buy and try and install at some point...


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
9 Posts
Hi guys. I'm from Brazil and I have an Up! tsi 2020 and I want to adjust cruise control on my car. I've been talking to two people who work with electrical repairs on the car, but they said the work is very dangerous because of the CAN-bus that have many risk to burn the bcm or another modules if you put one of the cables on the wrong place. It's really true or if I make de wiring and follow the diagram will be work correctly? I really have to worry about this or it's just install the wiring and stalk and before activate the function on VCDS?
 

·
Registered
Joined
·
9 Posts
Hi guys. I'm from Brazil and I have an Up! tsi 2020 and I want to adjust cruise control on my car. I've been talking to two people who work with electrical repairs on the car, but they said the work is very dangerous because of the CAN-bus that have many risk to burn the bcm or another modules if you put one of the cables on the wrong place. It's really true or if I make de wiring and follow the diagram will be work correctly? I really have to worry about this or it's just install the wiring and stalk and before activate the function on VCDS?
I've been retrofitted cruise control in my car, but appears these faults. Can anyone help me?

Address 01: Engine (J623-CYTA) Labels: None
Part No SW: 04C 906 026 CD HW: 04C 907 309 AD
Component: R3 1.0l TFS H24 5790
Revision: WDH24---
Coding: 01110012232400000000
Shop #: WSC 00046 000 00000
ASAM Dataset: EV_ECM10TFS01104C906026CD 001001
ROD: EV_ECM10TFS01104C906026CD.rod
VCID: 65CBEC566461CF6734-8030

2 Faults Found:
4481 - Cruise Control Switch (E45)
P0568 00 [047] - Implausible Signal
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 6
Mileage: 8459 km
Date: 2009.14.31
Time: 01:39:17

Engine speed: 0.00 /min
Normed load value: 0.0 %
Vehicle speed: 0 km/h
Coolant temperature: 63 °C
Intake air temperature: 50 °C
Ambient air pressure: 890 mbar
Voltage terminal 30: 12.368 V
Unlearning counter according OBD: 40
Cruise Control System (CCS): status-Bits 0-7: 8
Accelerator pedal travel: 0.00 %
Cruise Control System (CCS): switch position-Bits 0-7: 64

4482 - Function Restriction due to Implausible Message(s)
U1112 00 [047] - -
Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 2
Fault Frequency: 6
Mileage: 8459 km
Date: 2009.14.31
Time: 01:39:12

Engine speed: 0.00 /min
Normed load value: 0.0 %
Vehicle speed: 0 km/h
Coolant temperature: 63 °C
Intake air temperature: 50 °C
Ambient air pressure: 890 mbar
Voltage terminal 30: 12.250 V
Unlearning counter according OBD: 40
Cruise Control System (CCS): status-Bits 0-7: 8
Accelerator pedal travel: 0.00 %
Cruise Control System (CCS): switch position-Bits 0-7: 0

Readiness: 0010 0001

-------------------------------------------------------------------------------
Address 03: ABS Brakes (J104) Labels: None
Part No SW: 1S0 614 117 T HW: 1S0 614 117 T
Component: EBC 460 MABS H26 0400
Serial number: 9469654
Coding: 12DF24E32AEF1054489C241354FE0840580100
Shop #: WSC 03310 453 00218
ASAM Dataset: EV_Brake1ABSEBC460TRW 001003
ROD: EV_Brake1ABSEBC460TRW_VW12.rod
VCID: 3C7D6932B76BAEAFBB-8068

No fault code found.

-------------------------------------------------------------------------------
Address 09: Cent. Elect. (J519) Labels:. 7E0-937-BCM-V1.clb
Part No SW: 7E0 937 089 C HW: 7E0 937 089 C
Component: BCM PQ25 MMI4 H82 0762
Revision: BB082001 Serial number: 55227337180532
Coding: 3AA92B0004A90600108800007C0ABC80F58062BC60860450220100420800
Shop #: WSC 01234 003 00001
VCID: 336F420E923561D76A-8066

Subsystem 1 - Part No: 5Z0 947 105 E
Component: DWA-Sensor 00 003 0008
Coding: 000000

Subsystem 2 - Part No SW: 18D 959 442 HW: 18D 959 442
Component: E221__MFL-YLG H01 0130
Serial number: 000000000A0351131218
Coding: 200000

No fault code found.

-------------------------------------------------------------------------------
Address 10: Park/Steer Assist (J446) Labels:| 1Sx-919-475.clb
Part No SW: 1SB 919 475 A HW: 1Q0 919 475
Component: PARKHILFE 3K H03 0013
Revision: -------- Serial number: 18081905015345
Coding: 108005
Shop #: WSC 03310 453 00218
ASAM Dataset: EV_EPHVA14VW120LA00 001001
ROD: EV_EPHVA14VW120LA00.rod
VCID: 4A913FEAEDBF001F39-801E

No fault code found.

-------------------------------------------------------------------------------
Address 15: Airbags (J234) Labels:| 5K0-959-655.clb
Part No SW: 1SB 959 655 B HW: 1SB 959 655 B
Component: VW10AirbagSAL 010 0007
Revision: -------- Serial number: 003ER3007XEF
Coding: 00000000000000000000000000000000414C
Shop #: WSC 03310 453 00209
ASAM Dataset: EV_AirbaVW10BPAVW12X 001001
ROD: EV_AirbaVW10BPAVN750_VW12.rod
VCID: 4FA72EFE16DD25376E-801A

Crash sensor for front airbag: driver side:
Serial number: 3557BRB405F5DHVK2PA1

No fault code found.

-------------------------------------------------------------------------------
Address 17: Instruments (J285) Labels:| 1Sx-920-xxx-17.clb-SRI1
Part No SW: 1SB 920 870 HW: 1SB 920 870
Component: KOMBI H31 0053
Revision: X0031003 Serial number:
Coding: 814A000000
Shop #: WSC 03310 453 00218
ASAM Dataset: EV_KombiUDSMM9RM10 A05808
ROD: EV_KombiUDSMM9RM10_A05_VW12.rod
VCID: 55ABDC9634015FE7A4-8000

No fault code found.

-------------------------------------------------------------------------------
Address 25: Immobilizer (J334) Labels:| 5K0-920-xxx-25.clb
Part No SW: 5K0 953 234 HW: 1SB 920 870
Component: IMMO H31 0053
Revision: X0031003 Serial number:
Coding: 000000
Shop #: WSC 00000 000 00000
ASAM Dataset: EV_ImmoUDSMM9RM10 A01702
ROD: EV_ImmoUDSMM9RM10_VW12.rod
VCID: 6AD19F6A8D7FE01F19-803E

No fault code found.

-------------------------------------------------------------------------------
Address 44: Steering Assist (J500) Labels:| 1Sx-909-144-44.clb
Part No SW: 1S1 909 144 P HW: 1S1 909 144 P
Component: EPS_ECU H51 1702
Coding: 0001000001010000
Shop #: WSC 03310 453 00218
ASAM Dataset: EV_SteerAssisNSK 014008
ROD: EV_SteerAssisNSK_014.rod
VCID: 40851DC2DB83CA4FE7-8014

1 Fault Found:
0067 - Terminal 30
U140A 00 [008] - Open Circuit
[New feature! Extended UDS fault detail is only supported by current gen. interfaces]
Intermittent - Confirmed - Tested Since Memory Clear
Freeze Frame:
Fault Status: 00000001
Fault Priority: 4
Fault Frequency: 1
Reset counter: 1

Voltage terminal 15: 12.140 V
Voltage terminal 30: 12.768 V
Engine speed: 0.00 /min
Vehicle speed: 50 km/h
Status: Initializing


End-------------------------(Elapsed Time: 02:35)--------------------------
 

·
Registered
Joined
·
171 Posts
your in the wrong pin on the ecu, ps if there is faults in the ecu(even if it´s fitted correct )it will not work ontil faults are cleared.
regards
Sören
 

·
Registered
Joined
·
9 Posts
your in the wrong pin on the ecu, ps if there is faults in the ecu(even if it´s fitted correct )it will not work ontil faults are cleared.
regards
Sören
so have a chance the pin of brazilian version ecu is different that schematic t16d posted by Halaro. Because i had plugged on the pin 29 in the ecu, but doesn't worked showing these errors. what a saw the ecu of my car has two connectors but none is 56 pin type. Have you ever seen this ecu version on your country?
 

·
Registered
Joined
·
171 Posts
here in the eu, there are some that have it in 62 i belive, but on these newer cars you have to look them up at the dealer or someone that can go true the wirring diagram off your vin number at ecu.
ps. if you don´t have start/stop in the car you don´t have anything in the pin 28 so many mistake pin 28/29/30
regards
Sören
 

·
Registered
Joined
·
9 Posts
here in the eu, there are some that have it in 62 i belive, but on these newer cars you have to look them up at the dealer or someone that can go true the wirring diagram off your vin number at ecu.
ps. if you don´t have start/stop in the car you don´t have anything in the pin 28 so many mistake pin 28/29/30
regards
Sören
4740

Yeah, mine doesn't have Start/stop. If I change the position pin on ecu and it's still wrong.Can I burn the ecu module or only send a wrong message? My connector it's T94 and polo 6R has these assignments, but I don't know it will work if I try. The dealer in my city don't want to pass the diagram. thanks
 

·
Registered
Joined
·
171 Posts
the numbers on the new ones , that i have heard is 56 and 62 if it´s not the 29
you can´t use the polo ones since it´s a diffrent car and may have another ecu type
regards
Sören
 

·
Registered
Joined
·
38 Posts
I’m installing mine this week fingers crossed. I bought the stalks, bcm and additional wiring last year..


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
38 Posts
View attachment 4740
Yeah, mine doesn't have Start/stop. If I change the position pin on ecu and it's still wrong.Can I burn the ecu module or only send a wrong message? My connector it's T94 and polo 6R has these assignments, but I don't know it will work if I try. The dealer in my city don't want to pass the diagram. thanks
whats your engine code?
 

·
Registered
Joined
·
38 Posts
well its not going great for me, I broke the light switch on removal but that's easily fixed. Ive fitted a new 90 bcm and stalks and installed wiring I purchased on ebay from kufatec? it seemed an easy solution but involves more wires than stated on these diagrams?

On power up I have changed the config on vcds and the cruise control doesn't work? I can see all the switches operating on measuring blocks?

Also I can not code my remote key?? Everything is fine. no alarms? Im wondering if the bcm I have fitted is faulty or and ive put the wire to ecu in the wrong plug? it says plug A 29 but how do I know which is plug A as I couldn't see any identification?
I have fitted the original bcm back and the remote works but wasn't sure if I cleared the memory it would allow me to recode?

struggling with motivation now, please help!!!
 

·
Registered
Joined
·
171 Posts
it´s the plug nearest the fender, if there are faults stored the in the ecu it will not work, if you used kl30 and not kl15 remote power it will only work one time, then you have to take the terminal off the battery before it works 1 time again,
there always remote power kl15, constant 12v ***** it up, regarding the remote you need to code them again clear all codes before, and you need to code the ecu for cruise
regards
Sören
 

·
Registered
Joined
·
38 Posts
it´s the plug nearest the fender, if there are faults stored the in the ecu it will not work, if you used kl30 and not kl15 remote power it will only work one time, then you have to take the terminal off the battery before it works 1 time again,
there always remote power kl15, constant 12v * it up, regarding the remote you need to code them again clear all codes before, and you need to code the ecu for cruise
regards
Sören
Thanks rix,

The plug closest to the fender? Do you mean the one with the longest cable as they are left and right?

I’ve coded the ecu but don’t understand what kl30 and kl15 is? Sorry.

Alarms wise I broke my headlamp switch so have ordered a new one. I’ll check again but would the alarm stop me adapting the key fob?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
171 Posts
ecu plug is the one closest to the fender aka the left side off the car.
kl 15 is switched power aka when key is out off ignition there is no 12v, kl30 has power all the time
regards
sören
 

·
Registered
Joined
·
38 Posts
ecu plug is the one closest to the fender aka the left side off the car.
kl 15 is switched power aka when key is out off ignition there is no 12v, kl30 has power all the time
regards
sören
Ok thanks. I think I’ve put it on the wrong plug and not sure if the pins can be extracted? I’ll take a look tomorrow. Thanks


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
38 Posts
Thanks @RIX I relocated the pin and hey presto. All works!

Couple of problems I encountered following the post.....

1. To unplug the ecu cables I had to angle grind the metal brackets off that stop them being removed. It sounds drastic but I spent 2 hours trying to figure it out? I think on assembly at the factory they must pop rivet it all together..

2. I was heavy handed removing my headlamp light switch and broke it. Basically I turned to the left to remove not right ( while being depressed)

3. I swapped my bcm to a compliant one and as yet I haven’t been able to adapt the remote? I think it may be as I have alarms due to the broken switch? New one coming soon...

Overall would I do again? In short yes and I’ve gained a massive insight and knowledge but **** it was daunting. It’s cost me about £130 including bcm and 3 days on and off tinkering..


Sent from my iPad using Tapatalk
 
141 - 160 of 177 Posts
Top