Up Owners Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I've seen postings on here before about the poor connection between the Maps and more screen and the car, butI didn't realise it was quite so bad !

Took delivery of my car this week, and mindful of these postings, made sure the pillar and screen are very well seated.

Despite this, often the screen tries to shut down, as it think its been disconnected, or the summary screen contains no figures. Moving the screen around ( often to an odd angle ) finally makes the connection work, and the figures appear.

Is this all a bit rubbish ?

Anyone found a solution
 

·
Registered
Joined
·
705 Posts
Take it back to the dealer as it's not working properly.

Nick
 

·
Registered
Joined
·
176 Posts
Had my up! for 6 months now. Originally removed the Maps n More every time it was in a car park or overnight. Frankly got bored with taking it off and replacing with the blanking plug, and it is now never removed.

However, in all that time, fiddling with it, on/off, change the angles etc I have never had a single problem.

Your question "is this all a bit rubbish?" may well apply to a number of people who will reply to your post, listing all the problems they've had with the unit.

But once again the vast majority will have had no problems, will be satisfied, but will not post on this forum with just a positive comment.

Technologically it's not state of the art, and it would be nice if the whole unit stored itself in the dash (for instance)

But remember, you've bought a city car, built to specific costs and I would say that to get something like the Maps n More on a car costing what it does is pretty good going.
 

·
Registered
Joined
·
553 Posts
We have just returned, quite literally, from a trip down to northern Spain from sunny Lancashire.
I can assure you the M&M is worth its weight in gold! I love the way it zooms in and out depending on your speed and the helpful symbols displayed for petrol stations and supermarkets etc. we never got stuck with haveing to buy fuel on the motorways.
We also experienced some weather info displayed on the map in the form of snow flake in a red triangle which we though must be a mistake, until it started to snow!
We managed well over 50mpg and averaged over 60mph for the trip down, have yet to check for the return trip.
 

·
Registered
Joined
·
811 Posts
I think that it is brilliant for the price. A built - in system tends to cost 3 times as much and certainly wouldn't be 3 times as good. I'm very happy with mine.
 

·
Registered
Joined
·
202 Posts
i havent got one or ordered one but as an IT guy I'd suggest connecting it to the pc and making sure you have the latest updates and then if you have the same problems go to the dealers
 

·
Registered
Joined
·
304 Posts
You need to ensure its fully connected with the dash. Even when you think it's fully seated with a push it clicks in properly. Push it in to the connector and then push each side down until its firm. It's not very positive in its connection I'm afraid...

You should then have numbers in the information for the car... It's a knack of clipping it in but once learned you will do it every time right.
 

·
Registered
Joined
·
393 Posts
I agree. The M&M unit for the money (but mine came as standard in my High Up) is amazing! It has features that you can't even get on some built-in sat nav's on cars well over twice the price! It can be a hassle to keep putting it in/ taking it out, but just remember, that Aygo / C1 / 107 owners are only just lucky enough to get a rev counter, with no option for anything like sat nav, and they're similar money!


Matt
 

·
Registered
Joined
·
88 Posts
Getting the stalk connected to the dash can be the tricky bit. A couple of times I've thought it "clicked" into place but it needed another push to bed it in properly.

As noted above, it isn't easy to be sure that the unit is correctly fixed to the dash.

A few of the functions such as sat nav and the phone will work even if the stalk isn't properly connected. I go to the "media" section and check that the "radio" button isn't greyed out to double check.

But when up and running the unit is excellent - even the voice recognition works fine for me.

The only downside is the appalling Navigon Fresh software that just won't work on my Mac. I've given up hope of purchasing map updates for the thing now...
 

·
Registered
Joined
·
86 Posts
My M&M is extremely slow is this the same as everybody else's?
 

·
Registered
Joined
·
176 Posts
Bekahb said:
My M&M is extremely slow is this the same as everybody else's?

Dunno about anyone else's, but mine is certainly not. Switches very quickly between the 4 main displays and equally quickly between the lesser options. No complaints here.

Suggest you pop back to the dealers, have a play with the demo car. If yours is still slow, suggest you get the dealer to replace under warranty. That's what it's there for. Good luck!
 
1 - 11 of 11 Posts
Top