Up Owners Club banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1


As a newbie Up! owner I am having problems charging my Maps & More unit.
It was plugged in to my PC for over 6 hours yesterday, an hour in the car today and then another 3 hours on the PC again(still on at present) but I cannot get it to show fully charged. The charging light on the base still shows Amber. Anyone else had any issues getting it to fully charge and show green?

Also is there a way to get the screen just to show where you are without setting a route and destination?

Love my Up though!
 

·
Registered
Joined
·
397 Posts
Jaws said:
a) Anyone else had any issues getting it to fully charge and show green?
b) Also is there a way to get the screen just to show where you are without setting a route and destination?
b) Yes - just tap on Navigation then, via Options, tap on Show Map.

I have printed out all 140(ish) pages of the manual - and have studied in depth the Maps section and also the ON/OFF mounted and unmounted sections because I have a problem!

It should normally go into standby when the ignition key is withdrawn, and it should turn back on when the ignition is next switched on. It has always done this except for two occasions where my Unit has turned itself off whilst mounted in the car. I've had to operated the "Press RESET with a sharp point whist pressing the On/Off button at the same time."
If it happens a third time I will return it for a replacement (which the Dealer offered the first time it happened!)

a) Suggest you leave it for a good long time (say 24 hrs) to fully charge (either via USB or mounted in the car). If still amber, then something wrong with unit?
 

·
Registered
Joined
·
121 Posts
Jaws said:


As a newbie Up! owner I am having problems charging my Maps & More unit.
It was plugged in to my PC for over 6 hours yesterday, an hour in the car today and then another 3 hours on the PC again(still on at present) but I cannot get it to show fully charged. The charging light on the base still shows Amber. Anyone else had any issues getting it to fully charge and show green?
Bear in mind it will charge slowly via a PC USB port (which can only supply 0.5A), and perhaps not at all if the screen is on at the same time.

I've only ever charged mine using the dash mount and I've never even given the state of charge a second thought.

Does the state of charge even matter unless you're using it outside of the Up anyway?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thanks PeterWestSussex, having left my unit on to charge for nearly 24 hours finally got the fully charged green light on. Switched unit off and put it in its case. Tried to switch it back on today to try getting the map up without a destination and it wouldn't switch on at all. Had to do a hard reset and now it seems to be totally discharged again. Will see how long it takes to charge up. Think an e-mail to the dealer is in the offing! Good luck with yours!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks Juux. Finally managed to get unit fully charged via USB. It is important to know the state of charge when not connected to the vehicle particularly when downloading or updating maps etc. If unit is not fully charged it often causes the download to timeout and/or fail.
 
1 - 5 of 5 Posts
Top