Up Owners Club banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there,

Posted this on the Skoda forum but was told that you were very accepting of Citigo owners on here :LOL:

I took my 2012 Citigo in for a battery replacement last week and since then the radio won't turn on or off with the ignition! If I start the car then turn the radio on, my Bluetooth won't connect either (via satnav unit) but connects fine if the engine is off. I called the garage to query this and they said the error is with my ignition switch and a new one will cost £112 fitted. I understand it could be an issue with my ignition switch but just seems strange to happen immediately after a battery replacement? Any ideas?
 

·
Registered
Joined
·
2,604 Posts
Detection of the key being present in the steering lock, I think, may control more than just the radio. "Safe lock" activation, if fitted, may be one - on mine, the safe lock text flashes on the display on key removal.

If there are other things controlled by key presence, and if they also fail, then the lock theory might right, but it's a bit of a coincidence that it failed at the time the car was serviced. If you have stop-start the new main battery would need to have been coded into the ECU, but that may be unrelated. Try disconnecting and reconnecting the main battery with the key in the lock.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Detection of the key being present in the steering lock, I think, may control more than just the radio. "Safe lock" activation, if fitted, may be one - on mine, the safe lock text flashes on the display on key removal.

If there are other things controlled by key presence, and if they also fail, then the lock theory might right, but it's a bit of a coincidence that it failed at the time the car was serviced. If you have stop-start the new main battery would need to have been coded into the ECU, but that may be unrelated. Try disconnecting and reconnecting the main battery with the key in the lock.
The reason I took the battery in for a replacement was that my stop-start had stopped working, I assume it's been coded in correctly as it is working fine now. I also have a dashcam wired in which turns on with the ignition but no longer turns off when the key is removed. Do you still think I should go ahead with disconnecting and reconnecting the battery? Thanks for all your help!
 

·
Registered
Joined
·
2,604 Posts
A new battery will mean your stop-start works, no matter what. The coding thing is about giving the ECU a hint about how well your battery is likely to perform, for stop-start puposes, given some profile data about the battery, and it may affect how the smart alternator chooses how much to charge it up. It may be marginal; it's hard to know for sure!
 

·
Registered
Joined
·
49 Posts
Hi there,

Posted this on the Skoda forum but was told that you were very accepting of Citigo owners on here :LOL:

I took my 2012 Citigo in for a battery replacement last week and since then the radio won't turn on or off with the ignition! If I start the car then turn the radio on, my Bluetooth won't connect either (via satnav unit) but connects fine if the engine is off. I called the garage to query this and they said the error is with my ignition switch and a new one will cost £112 fitted. I understand it could be an issue with my ignition switch but just seems strange to happen immediately after a battery replacement? Any ideas?
Hi, i am having the same problem with my vw up, the radio does not switch off when the ignition is off, i also had a new battery fitted and this has happend since then |! did you get the problem solved as i cannot find anyone who knows what to do ! only VW which is going to cost a lot of money. Many thanks
 

·
Registered
Joined
·
2,604 Posts
Cars with stop-start may need to have the coding from their new batteries entered into the ECU - since there are two people with the same radio problem following a battery change, this may not be far-fetched!

In any case, we are waiting to see if the other member has had any success with their radio, by disconnecting/reconnecting the battery to force a reset (etc etc)
 
1 - 6 of 6 Posts
Top